#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=NitroCams_)(\d+)(-\d+-)(\d+)"
Local $sString = "какоетоимя_NitroCams_11-07-2021_03-44-00-proxy.ts"
Local $sSubst = "$3$2$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)