#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\\)[^\\]+$"
Local $sString = "C:\Users\KlausP\Pictures\Screenpresso\201.8-01-24_13h40_38.png" & @CRLF & _
"\\Users\KlausP\Pictures\Screenpresso\201.8-01-24_13h40_38.png" & @CRLF & _
"\\my-local-server\path\to\this_file may_contain-any&character.pdf" & @CRLF & _
"\\my-local-.net\server\path\to\this_file may_contain-any&character.pdf" & @CRLF & _
"\\my-local-.netd\server\path\to\this_file may_contain-any&character.pdf" & @CRLF & _
"\\my-local-.netd\server\path\to\this_file may_contain-any&character" & @CRLF & _
"\\my-local-.netd\server\path\to\.this_file may_contain-any&character" & @CRLF & _
".\hallo" & @CRLF & _
".\.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")