re = /(?<=\\)[^\\]+$/m
str = 'C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
\\\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
\\\\my-local-server\\path\\to\\this_file may_contain-any&character.pdf
\\\\my-local-.net\\server\\path\\to\\this_file may_contain-any&character.pdf
\\\\my-local-.netd\\server\\path\\to\\this_file may_contain-any&character.pdf
\\\\my-local-.netd\\server\\path\\to\\this_file may_contain-any&character
\\\\my-local-.netd\\server\\path\\to\\.this_file may_contain-any&character
.\\hallo
.\\.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end