#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\. | mL |x "
Local $sString = "1x 3.5 mL SST. 1x 4.0 mL gray cap cryovial."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)