# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:v(?:s?\.|:)?)\s*(.*)"
test_str = ("Zinaida Shumilina et al. v. Belarus \n"
" \n"
"CCPR/C/120/D/2142/2012\n"
"K.E.R. vs. Canada \n"
" \n"
"CCPR/C/120/D/2196/2012 \n"
"Lounis Khelifati v Algeria \n"
" \n"
"CCPR/C/120/D/2267/2013\" \n"
"Hibaq Said Hash v. Denmark \n"
" \n"
"CCPR/C/120/D/2470/2014\" \n"
"Anton Batanov v. Russian Federation \n"
" \n"
"CCPR/C/120/D/2532/2015\"\n"
"S. Z. v. Denmark \n"
" \n"
"CCPR/C/120/D/2625/2015\" \n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.