const regex = /^[0-9]+\.[0-9]+\.[0-9]+(-([a-zA-Z]+)?[0-9]*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]+\\.[0-9]+\\.[0-9]+(-([a-zA-Z]+)?[0-9]*)?$', 'gm')
const str = `1.0.0
1.0.0-0
1.0.0-42
1.0.0-alpha
1.0.0-alpha1
1.0.0-alpha42
1.0.0-anything
1.0.0-anything1
1.0.0-anything42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}