re = /\d(?:\s?\d){13,}(?:\s?C)?/m
str = '"Hello test 1 23 45 678 901 234 C test test2"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end