package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,4}[_].*`)
var str = `1234_test.mp3
999_test.mp3
12_test.mp3
0_test.mp3
0t_est.mp34
t_est1234.mp3
@_test.mp3
/_test.mp3
\\_test.mp3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}