const regex = new RegExp('^\\d{1,4}[_].*', 'gm')
const str = `1234_test.mp3
999_test.mp3
12_test.mp3
0_test.mp3
0t_est.mp34
t_est1234.mp3
@_test.mp3
/_test.mp3
\\\\_test.mp3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}