use strict;
my $str = '1234_test.mp3
999_test.mp3
12_test.mp3
0_test.mp3
0t_est.mp34
t_est1234.mp3
@_test.mp3
/_test.mp3
\\\\_test.mp3
';
my $regex = qr/^\d{1,4}[_].*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}