re = /^\d{1,4}[_].*/m
str = '1234_test.mp3
999_test.mp3
12_test.mp3
0_test.mp3
0t_est.mp34
t_est1234.mp3
@_test.mp3
/_test.mp3
\\\\_test.mp3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end