// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,4}[_].*").unwrap();
let string = "1234_test.mp3
999_test.mp3
12_test.mp3
0_test.mp3
0t_est.mp34
t_est1234.mp3
@_test.mp3
/_test.mp3
\\\\_test.mp3
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}