package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`\$scope\.[a-zA-Z]*\s\=\[`)
    var str = `$scope.proveedores =[{asdk oiaduas asoid a}]
$scope.cleintes =[{asdk oiaduas asoid a}]
$scope.ubicaciones =[{asdk oiaduas asoid a}]
$scope.loremipsum =[{asdk oiaduas asoid a}]`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}