import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$scope\\.[a-zA-Z]*\\s\\=\\[";
final String string = "$scope.proveedores =[{asdk oiaduas asoid a}]\n\n"
+ "$scope.cleintes =[{asdk oiaduas asoid a}]\n\n"
+ "$scope.ubicaciones =[{asdk oiaduas asoid a}]\n\n"
+ "$scope.loremipsum =[{asdk oiaduas asoid a}]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}