const regex = /([A-Z]|D[ei][A-Z]|Mc[A-Z]|Mac[A-Z]|O[`'])[a-z]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]|D[ei][A-Z]|Mc[A-Z]|Mac[A-Z]|O[`\'])[a-z]+', 'g')
const str = `Standard
StAndard
DeDonno
Dabc
O'reilly
GaGBec
Diflora
DiFloria
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}