re = /([A-Z]|D[ei][A-Z]|Mc[A-Z]|Mac[A-Z]|O[`'])[a-z]+/
str = 'Standard
StAndard
DeDonno
Dabc
O\'reilly
GaGBec
Diflora
DiFloria
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end