re = /--([^:=]+)[:=](.*?)(?=\s+--|\z)/
str = '--property:value --property:value with spaces --property:value_with_underscores --property=value --property=value with spaces --property=value_with_underscores --property:value-with-dashes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end