using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^#\| label: .+)_";
string substitution = @"-";
string input = @"#| label: this_this_is_a_test
my_function_name <- function(x)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}