using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:['""]?([\\\w\d ]+)['""]?(?:,\s*)?)";
string input = @" 'font1', 'font 2', font3, ""font 4 1"", ""\C560\D50C SD \C0B0\B3CC\ACE0\B515 Neo"";";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}