package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z]+):\/\/([^\/]+)\/?([^:]+):?(\d+)?$`)
var str = `ftp://nobodyloves.aweirdo.com/bonus:2101
http://www.lexusnexus.com/index.html
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}