$re = '/^([a-z]+):\/\/([^\/]+)\/?([^:]+):?(\d+)?$/m';
$str = 'ftp://nobodyloves.aweirdo.com/bonus:2101
http://www.lexusnexus.com/index.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);