const regex = /Domaine\s?([A-Za-z\u00C0-\u017F]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Domaine\\s?([A-Za-z\\u00C0-\\u017F]+)', 'g')
const str = `T. G.
Consultant JAVA/J2EE
Anglais/Français/Chinois
SYNTHESE
Programmeur et analyste JAVA/J2EE
Conception d’architectures Web
Domaine immobilier et bancaire
FORMATION ET LANGUES
2005-2007 Maîtrise en Génie Informatique, École Polytechnique de Montréal, Canada
2003-2004 Licence en Informatique, Université Denis Diderot (Paris, France)
1996-2000 Licence en EEA (Automatisme, Electronique), Université de Science et Technologie de Dalian,
Chine
DOMAINE D’EXPERTISE
Systèmes Unix (SUSE), Linux, Windows 9X/NT/2000/XP/Vista, Max OS
Protocoles LAN, WAN, HTTP, TCP/IP, SMTP, POP3
Langages Java, Html, JavaScript, Sql, C, C++, Perl, XML (DOM, SAX)
JAVA/J2EE Java, JSP, Servlet, JDBC, Swing, JUnit, Maven, Ant
Framework Struts, Hibernate, Spring, Webwork
Web: Ajax, CSS, Prototype, Php5
Bases de Données Oracle 9i/10G, MySql, SqlServer
Serveurs d’applic Apache, Tomcat, JBoss, Weblogic
IDE Eclipse, MyEclipse, Visual Studio, CVS, Visio
Méthodes UML (Use Case, diagrammes de classes/séquences/activité), Agile/Scrum
EXPERIENCE PROFESSIONNELLE
Janvier 2008 à ce jour : Logiciels Prospects Inc, Montreal
Programmeur Analyste JAVA/J2EE, Projet "Prospects Web", Solution destinée aux agents immobiliers
pour la gestion des contacts, des activités et des propriétés, au sein d’une équipe de 16 personnes
composée d’un Lead technical, 2 QA, 6 développeurs chef .
Prospects Web est un outil qui vise à gérer et simplifier le travail d’un agent immobilier. Cette application est
réalisée avec les technologies J2EE et utilise plusieurs Framework de Apache. Cet outil a deux versions : une
version de base et une version professionnelle. La version de base offre des fonctionnalités de gestion des
contacts et des propriétés, un système courriel et un calendrier personnel. La version professionnelle offre en
plus des fonctionnalités comme l’évaluation du marché, l’analyse des ventes, la gestion des documents et le
match (trouver automatiquement les inscriptions satisfaits aux critères de recherche). L’application possède
aussi une interface qui permet aux usagers de synchroniser les activités et les contacts avec leurs appareils
mobiles. Ce système est utilisé par plusieurs chambres immobilières au Canada et aux États-Unis. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}