$re = '/(.*)(;)(.*)/';
$str = 'asdf[;asdf]';
$subst = ";$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;