// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<year>\d{4})(?<month>\d{1,2})(?<day>\d{1,2})").unwrap();
let string = "19911231";
let substitution = "${year}-${month}-${day}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}