re = /Serial Number: (\S*)$/m
str = 'Cisco Adaptive Security Appliance Software Version 9.12(1)2
ASAv1 up 23 mins 50 secs
Serial Number: 9A2AL26E95V'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end