package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(@(\w+))`)
var str = `Как заменить отметки/теги (#tag или @user_name) на ссылки с помощью Regex?
К примеру, есть текст поста, в котором есть отметки (@username, @user_login) или теги (#tag, #second_tag).
Нужно их заменять на html-ссылки:
@user_login на @user_login).`
var substitution = "<a href='/users/$2'>$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}