#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\newcommand{\\(.*?)}(\[(\d)\])?{(.+)}"
Local $sString = "\newcommand{\vA}{\mathbf{A}} % Vanilla command" & @CRLF & _
"\newcommand{\Exp}[2]{\mathop{\mathbb{E}}_{#1}\left[#2\right]} % Arguments" & @CRLF & _
"\newcommand{\Expect}[2][]{\mathop{\mathbb{E}}_{#1}\left[#2\right]} % Optional Argument" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")