import Foundation
let pattern = #"\\newcommand{\\(.*?)}(\[(\d)\])?{(.+)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
\newcommand{\vA}{\mathbf{A}} % Vanilla command
\newcommand{\Exp}[2]{\mathop{\mathbb{E}}_{#1}\left[#2\right]} % Arguments
\newcommand{\Expect}[2][]{\mathop{\mathbb{E}}_{#1}\left[#2\right]} % Optional Argument
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)