const regex = /(?=^\d+)^([78]\d{10}|[1]\d{9}|[0](?:\d{6}[78]|\d{7}[1])(?:\d{10}|\d{9}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^\\d+)^([78]\\d{10}|[1]\\d{9}|[0](?:\\d{6}[78]|\\d{7}[1])(?:\\d{10}|\\d{9}))', 'gm')
const str = `85556987456
75556987456
1555698745
000000085556987456
000000075556987456
000000001556987456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}