import re
regex = re.compile(r"(?=^\d+)^([78]\d{10}|[1]\d{9}|[0](?:\d{6}[78]|\d{7}[1])(?:\d{10}|\d{9}))", flags=re.MULTILINE)
test_str = ("85556987456\n"
"75556987456\n"
"1555698745\n"
"000000085556987456\n"
"000000075556987456\n"
"000000001556987456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")