use strict;
my $str = '10
1111100
1000000
11110000000
111111111111
000000001111
000011110000
00000000111100
000000001111000
0000000011110000';
my $regex = qr/0*(?|(1[10]{6})|([10]{6}1))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}