$re = '/0*(?|(1[10]{6})|([10]{6}1))/m';
$str = '10
1111100
1000000
11110000000
111111111111
000000001111
000011110000
00000000111100
000000001111000
0000000011110000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);