#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^1?(0*11+)*0*1?$"
Local $sString = "accepts:" & @CRLF & _
"001" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"1110011" & @CRLF & _
"100110" & @CRLF & _
"001100" & @CRLF & _
"rejects:" & @CRLF & _
"010" & @CRLF & _
"111010" & @CRLF & _
"01000000"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)