use strict;
my $str = 'accepts:
001
0
1
1110011
100110
001100
rejects:
010
111010
01000000';
my $regex = qr/^1?(0*11+)*0*1?$/mp;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";