// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^1?(0*11+)*0*1?$").unwrap();
let string = "accepts:
001
0
1
1110011
100110
001100
rejects:
010
111010
01000000";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}