import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(crayons|cars|camels)\\b(?:[^a-z\\n]*([a-z]*)[^a-z\\n]*([a-z]*))";
final String string = "there are many crayons, in the blue box crayons that are',\n"
+ "cars! i like a lot of sports cars because they go fast',\n"
+ "the camels, in the middle east have many camels to ride,\n"
+ "some more example with edge case camels\n"
+ "some hyphense words see-camels should it match ??\n"
+ "hello test string cars one\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}