const regex = new RegExp('\\b(crayons|cars|camels)\\b(?:[^a-z\\n]*([a-z]*)[^a-z\\n]*([a-z]*))', 'gmi')
const str = `there are many crayons, in the blue box crayons that are',
cars! i like a lot of sports cars because they go fast',
the camels, in the middle east have many camels to ride,
some more example with edge case camels
some hyphense words see-camels should it match ??
hello test string cars one
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}