use strict;
my $str = 'there are many crayons, in the blue box crayons that are\',
cars! i like a lot of sports cars because they go fast\',
the camels, in the middle east have many camels to ride,
some more example with edge case camels
some hyphense words see-camels should it match ??
hello test string cars one
';
my $regex = qr/\b(crayons|cars|camels)\b(?:[^a-z\n]*([a-z]*)[^a-z\n]*([a-z]*))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}