re = /\b(crayons|cars|camels)\b(?:[^a-z\n]*([a-z]*)[^a-z\n]*([a-z]*))/mi
str = 'there are many crayons, in the blue box crayons that are\',
cars! i like a lot of sports cars because they go fast\',
the camels, in the middle east have many camels to ride,
some more example with edge case camels
some hyphense words see-camels should it match ??
hello test string cars one
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end