// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b(crayons|cars|camels)\b(?:[^a-z\n]*([a-z]*)[^a-z\n]*([a-z]*))").unwrap();
let string = "there are many crayons, in the blue box crayons that are',
cars! i like a lot of sports cars because they go fast',
the camels, in the middle east have many camels to ride,
some more example with edge case camels
some hyphense words see-camels should it match ??
hello test string cars one
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}