# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(pensionsrü\w*)\s[\D]*(\d*[.,]?\d*[,.]?\d*\s?[€%])"
test_str = ("Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000€\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10000€\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000 €\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10000 €\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00€\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00€\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00 €\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00 €\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 100 €\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 100€\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00 €\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00€\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2% vom Vorjahresumsatz\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2% des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland.\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland: NRW und/oder Hessen.\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % vom Vorjahresumsatz\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03% vom Vorjahresumsatz\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3% vom Vorjahresumsatz\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03 % vom Vorjahresumsatz\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3 % vom Vorjahresumsatz\n\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03% vom Vorjahresumsatz\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3% vom Vorjahresumsatz\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03 % vom Vorjahresumsatz\n"
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3 % vom Vorjahresumsatz")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.