import Foundation
let pattern = #"(pensionsrü\w*)\s[\D]*(\d*[.,]?\d*[,.]?\d*\s?[€%])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100€
Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 2% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2% des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland.
Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland: NRW und/oder Hessen.
Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3 % vom Vorjahresumsatz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)