# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=CHEM|HIST)\s*|(?<=MATHS)\s*"
test_str = ("CLASS 8B CHEM | MON | 10AM to 10:40AM\n"
"--Rescheduled-- CLASS 8B MATHS | MON | 11AM to 11:40AM\n"
"CLASS 8B HIST | MON | 5PM to 5:40PM'\n"
"CLASS 8B CHEM | MON | 10AM to 10:40AM\n\n")
subst = "<A-WHITE-SPACE>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.