using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<iframe[\s]+?src=""(http[s]*:\/\/)?www\.youtube\.com\/embed\/([a-zA-Z0-9-_]{11})[^""]*""[^>]*?><\/iframe>";
string input = @"<iframe src=""https://www.youtube.com/embed/lfLRV19y6hg?disablekb=1&rel=0&showinfo=0"" width=""780"" height=""439"" frameborder=""0"" allowfullscreen=""allowfullscreen""></iframe>
<iframe src=""https://www.youtube.com/embed/3xzCyOdf4Qc?disablekb=1&rel=0&showinfo=0"" width=""780"" height=""439"" frameborder=""0"" allowfullscreen=""allowfullscreen""></iframe>
<iframe src=""https://www.youtube.com/embed/JtpT4LLxFv4?disablekb=1&rel=0&showinfo=0"" width=""780"" height=""440"" frameborder=""0"" allowfullscreen=""allowfullscreen""></iframe>
<iframe src=""https://www.youtube.com/embed/R6UAHzmxJ_g?disablekb=1&rel=0&showinfo=0"" width=""780"" height=""439"" frameborder=""0"" allowfullscreen=""allowfullscreen""></iframe>
<iframe src=""https://www.youtube.com/embed/DIFGObcX9A4?disablekb=1&rel=0&showinfo=0"" width=""780"" height=""439"" frameborder=""0"" allowfullscreen=""allowfullscreen""></iframe>
<iframe src=""https://www.youtube.com/embed/HtDEqzAk_48?disablekb=1&rel=0&showinfo=0"" width=""780"" height=""439"" frameborder=""0"" allowfullscreen=""allowfullscreen""></iframe>
<iframe src=""https://www.youtube.com/embed/n5GpN1Xa4q0?disablekb=1&rel=0&showinfo=0"" width=""780"" height=""439"" frameborder=""0"" allowfullscreen=""allowfullscreen""></iframe>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}