import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\r?\\n){2}|^)([^\\r\\n]*\\|[^\\r\\n]*(\\r?\\n)?)+(?=(\\r?\\n){2}|$)";
final String string = "\n"
+ "item | test\n"
+ "------|:-----:\n"
+ "test2 | lol\n\n\n"
+ "blannlalbablabla\n\n"
+ "item | test\n"
+ "------|:-----:\n"
+ "test2 | lol\n\n\n\n\n\n"
+ "test | foo\n"
+ "bla | yo\n\n"
+ "jljhkjgkgkj";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}