$re = '/((\r?\n){2}|^)([^\r\n]*\|[^\r\n]*(\r?\n)?)+(?=(\r?\n){2}|$)/m';
$str = '
item | test
------|:-----:
test2 | lol
blannlalbablabla
item | test
------|:-----:
test2 | lol
test | foo
bla | yo
jljhkjgkgkj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);