re = /((\r?\n){2}|^)([^\r\n]*\|[^\r\n]*(\r?\n)?)+(?=(\r?\n){2}|$)/m
str = '
item | test
------|:-----:
test2 | lol
blannlalbablabla
item | test
------|:-----:
test2 | lol
test | foo
bla | yo
jljhkjgkgkj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end