$re = '/(?:^|[^-+.()\w])(hello)(?![-+.()\w])/m';
$str = 'hello
+hello
-hello
hello+
ahello
helloa
&hello
hello%
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;