import Foundation
let pattern = #"(?:^|[\W])(@\w{1,20})(?:$|[\W])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
@ih knkl @gs fsdf@ijkjdsfkl "@_dsfkoj" @sdkj-s @ℍ𝕦𝕘𝕠𝕄𝕠𝕤𝕙 s @ljbhdkj_sa3 wefd s|jhh "@nksdm" hugo@mis.com @dsf
@𝕘𝕠𝕄𝕠𝕤𝕙 dfs @! @fdsdfasdfsdfsdfsdfsdfs @last @k @jj. @sdf.sd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)