use strict;
my $str = ' `wallet_number` varchar(15) NOT NULL,
`created_by` bigint(20) DEFAULT NULL,
`updated_by` bigint(20) DEFAULT NULL,
`deleted_by` bigint(20) DEFAULT NULL COMMENT \'Due date of task\',
`status` int(11) NOT NULL,
`comment` longtext,
`createdAt` datetime DEFAULT NULL,
`updatedAt` datetime DEFAULT NULL,
PRIMARY KEY (`wallet_number`)';
my $regex = qr`^\s*\x60(\w*)\x60\s*(.*?)(?:COMMENT \'(.*)\')?,$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}